Windows 7 Plunge

Plan of Attack

After my RAID/hard drive debacle, I figured it was time to start with a clean slate.  Usually with my Windows boxes over the years, I would start with a clean drive and reinstall/upgrade OS to clear out the bloat.  I would accumulate all kinds of apps and drivers that just cluttered up the joint.  This situation was no different.  I did find out something though…..it was more than one of my faulty drives in the RAID pair.  I bought Win 7 32-bit (mistake 1), and then installed on my system with same hardware (mistake 2).  My hardware was decent enough (4 core AMD, 4G RAM, ATI 4xxx series) and OS installed without a hitch.  However 2nd day after install I was repopulating my working drive folders with pictures, video, etc. and I thought I would play a video of gypsy band playing in a pub from our Czech Republik trip and I got the stuttering, frozen black screen, and loss of mouse cursor.  Essentially everything that happened right before that faulty drive got hosed (I was playing back a TiVo video from TiVo-to-go then).  OK, so my video card and/or motherboard became unstable.  The motherboard had the Japanese solid state capacitors and all looked OK (but that may be the issue as there is no visible place for them to bulge – they may just up and die without a visual clue).

Regroup

Time for a whole new system.  Might as well – I noticed that the motherboard had DDR2 RAM in it, so it had been a while since that was built.  So I sprung for everything (new case, 6 core CPU,  mboard, video card, RAM, blu ray combo player).  And correcting for mistake 1, I purchased Win 7 64-bit.  Price-wize, it was a teeny bit more to buy a new OEM Win 7 Pro, than to do an AnyTime upgrade.  The key point was you cannot do an ‘Anytime Ugrade’ to go from 32-bit to 64-bit system.  Nuff said, it was time to build and install.  Because I was going to have a dual-boot system, I needed to install Windows first and Ubuntu second.  Windows install was straightforward, but longer than the 32-bit install (I guess it had to have all of 64-bit and some of 32-bit to run in compatibility mode) I had done.  Once I got Win 7 up and running, wiped out one of my internal drives that had an old XP system on it (quick-formatted to NTFS).  Then I took my Ubuntu 11.10 live/install disk and rebooted with it.  because I have 3 drive (4 with USB external) with a bunch of partitions, it can get confusing with a Linux install, so I chose to cancel install which basically brings up the Live Ununtu.  Then I went into disk manager and took a gander at my drives and partitions.  I wanted to make sure I had the right drive (since it was the only 100G drive it was easy) and wrote the device name down to be sure.  Then I proceeded to the install app on the Live system.  I made sure not to choose “Install Along Side of” option and chose the manual config option.  There I chose the empty 100G device name and formatted 95% of it for the system mounted on ‘/’, and the rest formatted at Swap partition.  The install continued without issues.  After the reboot, because I don’t like ‘Unity’ interface, I installed the old Gnome interface.  Ubuntu 11.10, unlike first version of 11, stripped out Synaptic and ability to change your login screen out-of-the-box.  Once the Gnome retro interface was installed, logging off and on allowed the interface change.  However, the ‘System’ menu is gone on the top menu bar.  At some point I may be forced to adapt to Unity interface, but I’ll give it a go with ol’ Gnome for a bit.

 

Jury is Out

Well, I have set up a number of Win 7 boxes at the office – all new PCs and upgrades go to Win 7 Pro, but my work PC is still Vista Business.  Bottom line is I haven’t gotten too cozy with the OS just yet.  Now because I have it at home, I will have to get familiar with it, regardless.  Anyway, interesting Microsoft went back with ‘My Documents” like it used to be in XP days.  Look and feel issues are improvements over Vista – they got that right.  I do have one annoying issue (and I am not alone on this), and that is the power handling (sleep, hibernate, S1, S3, etc).  I never had any issues with Vista and waking up the system after sleep (I enabled wake on-mouse in bios).  In my brief exposure to Win 7 32-bit, the monitor went black after sleep and could not be repowered no matter what I did.  A cold reboot with power (4 second hold) was the only way to get it back.  The weird thing is the monitor power button was hijacked – pushing it did nothing – no orange light, no green light.  I chalked it up to the bogus video card and/or motherboard.  With a completely new system (nothing the same except the SATA system drive) the exact thing happens.  Like I mentioned, I am not the only one experiencing this.  It happens with ATI cards and NVidea, different bios(s), motherboards, etc. Quite prevalent – just Google ‘+windows 7 +monitor +blank +sleep’ and you’ll get plenty of hits.  The interesting thing is even after I put ‘Turn off display = never’ and ‘Put computer to sleep = never’, It still happened after an overnight update (default automatic install).  So what I have done as a work around is keep the power settings like the previous sentence and change ‘Update Settings’ to ‘Download, but install when I choose to’.  I also changed the bios power settings ‘wake’ triggers to S1 instead of S3.  I haven’t had a blank monitor issue for 4 days now, so I think that is behind me.  I did like it when I set my home PC to sleep after 5 hours of being idle and double-clicking mouse to turn back on.  That is how my wife’s Vista PC is and it is a great ‘green’ feature.  I will keep testing after future updates to see if it gets resolved.

The Positives

Besides the obvious issues with some legacy apps being unstable under 64-bit, I am happy with the performance of this new system.  After putting together, I ended up with an ‘Experience Score’ of 6, where my previous Vista system was 5.2.  The benefit I think will be the attractive part of the new system is the extended RAM access and the 6 cores.  This will be very handy in Blender (installed both in Win 7 and my 64-bit Ubuntu) and ArcGIS 10 (which can take advantage of the extra cores).

Posted under Operating Systems